Microsoft Email Delays

Minor incident Email Security Inbound Outbound
2023-10-11 11:49 BST · 3 hours, 28 minutes

Updates

Resolved

All mail that was queued due to the Microsoft service issue has now been delivered.

Microsoft is still investigating the issue on their end, but the recently added workaround has allowed mail to flow once again.

Microsoft made the following comment:

“We’ve identified that a recent service update, applied to a section of infrastructure responsible for enforcing IP address anti-spam rules, contains a change which is inadvertently causing impact. We’re developing and validating a fix to revert to the most recent stable service version to remediate impact. In parallel, we’re continuing to manually add reported affected IP addresses to an allowed list to alleviate impact in the short term.”

Unfortunately, they have not updated their status page to reflect this issue at any point.

October 11, 2023 · 15:18 BST
Update

We have had some communication from Microsoft stating that they have put some temporary fixes in place to resolve the issue but we will need to wait for at least an hour for the change to be reflected.

October 11, 2023 · 13:04 BST
Update

Some customers have been reporting delays delivering to Microsoft mailboxes. We have investigated the issue and it lies with Microsoft. We can only wait for Microsoft to resolve the issue on their end.

October 11, 2023 · 11:49 BST

← Back