Zimbra Webmail Issue Affecting Some Mailboxes

Minor incident Zimbra Email and Collaboration Webmail Inbound Outbound Proxy
2023-08-19 03:57 BST · 4 hours, 42 minutes

Updates

Resolved

We’re continuing to monitor but the issue with the mailbox server was resolved shortly after the earlier status post.

August 19, 2023 · 08:39 BST
Investigating

We are currently looking into an issue with one of our mail servers that is causing service degradation for some users

August 19, 2023 · 03:57 BST

← Back