Email Delays
Minor incident
Zimbra Email and Collaboration
Webmail
Inbound
Outbound
Proxy
Email Security
Inbound
Outbound
2020-01-06 10:46 GMT
· 1 hour, 32 minutes
Updates
Resolved
January 6, 2020 · 12:19 GMT
Mail delivery speeds should now be returning to normal.
Thank you for your patience.
Monitoring
January 6, 2020 · 10:46 GMT
Happy New Year to all!
With so many return to work and catching up on their Christmas emails we are seeing an unexpectedly large increase in traffic which is causing some minor email delays across our platform.
We apologise for this inconvenience and we are devoting resources to alleviate the issue as soon as possible.
← Back