Yahoo and AOL mail problems

Minor incident Managed WordPress Hosting Zimbra Email and Collaboration Webmail Inbound Outbound Proxy Reseller Control Panel Email Security Inbound Outbound
2019-09-05 11:54 BST · 5 hours, 23 minutes

Updates

Resolved

Yahoo have resolved the problem with their mail platform and all queued mail has been delivered

September 5, 2019 · 17:17 BST
Update

We’re currently queuing mail for some Yahoo domains and other domains using the same provider (Oath) due to a problem they’re having with their mail platform.

Queued emails will be automatically delivered once their mail platform returns to normal operation.

September 5, 2019 · 11:54 BST

← Back